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Copyright note 

The product and the information contained herein is subject to change without prior notification. 

This manual may not, in whole or in part, be reproduced or transmitted in any form either 
electronically or mechanically, including photocopying and recording, without the express written 
consent of HarmanBecker Automotive Systems. 

© 2008 – HarmanBecker Automotive Systems 

All rights reserved. 

Microsoft, Windows, Vista and Outlook are either registered trademarks or trademarks of Microsoft 
Corporation in the United States and/or other countries. 
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1 Getting started with the Content 
Manager 

The Content Manager is a PC-based application that has a number of important features to help you 
manage the content of your navigation device. With the Content Manager you can: 

• Backup the content stored on your device to your PC and restore it back to your device later. 

There are several types of navigation content that are loaded on your device and that can be used 
with the Content Manager. The content that is available depends on the device you originally 
purchased and the country where you purchased it. 

Content is broken down into smaller, more manageable pieces for each region or country. The 
various types of content that might be available include: 

• Maps are the road networks used by the navigation system to route your trips. 

• Landmarks (not available for all devices) are 3D artistic or block representations of prominent 
or well-known objects. 3D landmarks are only available in selected cities and countries. 

• 3D Cities (not available for all devices) are full 3D city building data representing actual 
building sizes and positions on the map. 3D cities building data availability is limited to the city 
centres of major cities. 

• POIs are Points of Interest, which are specific reference points that can be searched and 
navigated to. They are sorted into different categories like hotels, restaurants, tourist 
attractions, banks and many other locations users may want to find while they travel. 

• Phonemes (not available for all devices) are used by the Text to Speech navigation engine to 
announce the road names during navigation. Text to Speech voices are not available for all 
languages and can be set in the navigation software by selecting any voice profile with '(TTS)' 
in its name. 

• Relief (not available for all devices) is the 3D terrain map data showing changes in terrain and 
elevations or depressions in the land when you view the map. This is used to plot the route 
map in 3D during navigation. 

• Voice language is the voice profile used for navigation guidance. These are either pre-
recorded voices or Text to Speech voices. Text to Speech voice profiles are indicated by 
'(TTS)' and use artificial intelligence to announce route events together with road names during 
navigation. Non Text to Speech voices are recorded in the identified language and only 
announce route event types and distances without road names. 

• Application is the navigation software that is running on your Becker Traffic Assist. 

• Menu language is the list of available languages for the navigation software to display button 
labels and screen messages. 

• Schemes are different daytime and night colour profiles that let you personalise the look of the 
map in the navigation software. 
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System requirements 

To use the Content Manager, you need a USB cable, and a computer that meets the following 
minimum specifications. 

 Minimum Recommended 

Operating 
system 

Windows XP Windows Vista 

Processor 300 MHz clock 
speed 

Intel Pentium/Celeron family, or AMD K6/Athlon/Duron family, or 
compatible processor 

System 
memory 

256 MB 512 MB 

Free disk 
space 

2 GB 5 GB 

1.1 Installing the Content Manager 
Follow these steps to install the Content Manager on your computer: 

1. Insert the DVD with the Content Manager in the DVD drive of your PC. 

2. If the DVD does not start automatically, please manually start in the directory 
„CONTENTMANAGER“ the file „BECKERCMSETUP.EXE“. 

3. Select a language from the list, then click OK. 

4. Read the welcome page, and click Next to continue. 

5. Select the installation folder. A default installation folder is already given. To choose a different 
one, type in the path name, or click Browse, and select a different folder. 

6. Click Install to start the copying process. To see the details during copying, click Show 
Details. 

7. (optional) The Content Manager starts automatically right after the installation. To avoid this, 
clear the checkbox. 

8. The installation is complete, click Finish to exit. 

 

NOTE: The Content Manager has an auto-updating feature to ensure you always have the 
most up-to-date version on your PC. Each time you launch the application, it checks for 
available updates. 

1.2 Starting the Content Manager 
To start the Content Manager, do the following: 

1. Connect your Becker Traffic Assist to your PC. Wait for the PC to recognise the Becker Traffic 
Assist. If this is the first time you connect the Becker Traffic Assist to the PC, the PC will install 
all necessary drivers and then display the message: "Your device is ready to use". 

2. Click Start > All Programs. 

3. Select Becker. 

4. Click Content Manager. 

 

NOTE: We recommend that on each case you keep to create the backup. In case of a loss of 
data only then content can be restored. 
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1.2.1 Before startup 
When the Content Manager is started, it performs a few steps before you can start managing the 
content of your navigation software. 

It connects to the Internet to check for an available new Content Manager version at each startup. If a 
new software version is found, the Content Manager offers to install it. It is highly recommended that 
you always accept the upgrade, if it is available. If a new software version is found, you have the 
following options: 

• Click Yes to accept the new software version. The new version will be downloaded, installed, 
and then you can start using the Content Manager. 

• Click No to start the Content Manager with the old version already installed. 

• If the new version is an important upgrade, instead of the No button an Exit button will appear. 
You need to install the new version, otherwise you can only exit the application. 

If you have inserted the content DVD in the PC, the Content Manager will automatically read and 
catalogue the content of the DVD if it has not been added to the list of content DVDs before. For 
details, see page 16. 

If you have not created a backup of your navigation device before, the Content Manager will offer the 
possibility of a full or partial backup at each startup. For details, see page 15. We recommend that on 
each case you keep to create the backup. 

1.2.2 Selecting a device profile 
Every time you start the Content Manager with a new device, a different device profile needs to be 
created. The device profile selection screen appears. Give a profile name for the connected device, or 
accept the one automatically created. 

The Content Manager automatically recognises a device that has been used before. In this case the 
device profile screen does not appear, and the previously given profile name is used. 

1.2.3 Recovery 
If the content of the navigation software is damaged, the Content Manager cannot recognise it. If this 
happens, the Content Manager warns you, and you can attempt to recover it from a previously saved 
backup. Do the following: 

1. Connect your Becker Traffic Assist to your PC. 

2. Launch the Content Manager. 

3. Click Recovery at the warning message. 

4. Select the appropriate Profile name. The Device type appears automatically. 

5. The newest available Backup and the Drive letter is shown by default. Change them if 
necessary. 

6. Click Start to begin the recovery. 

7. Click Yes to confirm the warning message. 

 

NOTE: In order to perform a recovery, you need a full backup created with the Content 
Manager. Creating a full backup is recommended when you start using your navigation device.
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1.3 Controls 
When the Content Manager is started the first time, it opens in Advanced mode.  

The main window of the Content Manager is divided into the following sections: 

• the Menu bar 

• the Toolbar icons 

• the Contents list, all content items available for the connected device (available in Advanced 
mode only) 

• the Contents list filters: Status, Type and Location (available in Advanced mode only) 

• the Operations window (available in Advanced mode only) 

• the Information window 

Later you can switch to Simple mode in the View menu. This mode contains the full Tools menu and 
basic content management: 

•  Update all: Updates all contents on the device. Press the button, and then press Yes to 
confirm the operations summary. 

•  Install all: Installs all available new contents on the device. Press the button, and then 
press Yes to confirm the operations summary. 

1.3.1 Menu bar 
The Menu bar contains the following submenus: 

• File: 

• Exit: Quits the Content Manager. 

• Content (available in Advanced mode only): 

• Install: Installs the selected contents on the device.  

• Install all: Installs all available new contents on the device.  

• Update: Updates the selected contents on the device.  

• Update all: Updates all contents on the device.  

• Remove: Removes the selected contents from the device.  

• Operation (available in Advanced mode only): 

• Perform operations: Executes all content operations listed in the Operations window.  

• Remove operation: Cancels the selected content operations.  

• Clear operations: Cancels all content operations listed in the Operations window.  

• View: 

• Advanced mode: In this mode all content operations and tools are accessible. 

• Simple mode: This mode contains the full Tools menu and basic content management. 
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• Tools: 

• Transfer Trip Plans: This feature is not available in this version. 

• Backups: Launches the Manage backups screen to create a backup or recover one to 
your device.  

• Licences: Opens the list of active and inactive licenses on your Becker Traffic Assist, 
and lets you activate or deactivate them one by one. 

• Content DVDs: The Content Manager can read and catalogue the content of DVDs that 
are bought for or enclosed with the product. In this way you can install or reinstall 
content items on your device without an Internet connection. 

• Device Profiles: Lets you edit and remove the device profiles you have created. 

• Preferences: Lets you manage preferences available for the Content Manager. 

• Help: 

• Online support: Launches the product website using the Internet connection of the PC. 

• About: Version and copyright information of the Content Manager. 

1.3.2 Toolbar icons 
The icons under the menu bar perform the same actions as the menu items in the Content, 
Operation and Tools menus. 

The following icons are available in Advanced mode only: 

Icon Menu Item Function 

 

Content > Install Installs the selected contents on the device.  

 

Content > Update Updates the selected contents on the device.  

 

Content > Remove Removes the selected contents from the device.  

 

Content > Install all Installs all available new contents on the device.  

 

Content > Update all Updates all contents on the device.  

 

Operation > Perform 
operations 

Executes all content operations listed in the Operations 
window.  

 

Operation > Remove 
operation 

Cancels the selected content operations.  

 

Operation > Clear operations Cancels all content operations listed in the Operations 
window.  

The following icons are always available: 

Icon Menu Item Function 

 

Tools > Backups Launches the Manage backups screen to create a 
backup or recover one to your device.  
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1.3.3 Operations window (available in Advanced mode only) 
After selecting an action, it appears in the Operations window. The name, type and size of the 
content are displayed here together with the icon of the assigned action and the targeted storage 
location. 

All the content operations in the Operations window can be performed by clicking , or by clicking 
Perform operations in the Operation menu. 

1.3.4 Information window 
This window displays information about the connected device. The following parameters are shown: 

• The type of the device. 

• The name of the device profile. 

• The Before column displays the current amount of free storage space in the available storage 
locations. 

• The After column displays the amount of free storage space in the different storage locations 
after performing the currently selected operations. 

• The Capacity column displays the total amount of storage space in the different storage 
locations. 

• Update available for: The number of update packages is displayed together with their total 
required storage space. 

• Not installed: The number of packages not yet installed on the device is displayed together 
with their total required storage space. 

1.3.5 Contents list (available in Advanced mode only) 
The largest part of the Content Manager is the list of content elements available for the connected 
device. The columns of the list are as follows: 

• Name: The name of the content. This column can also include an icon that shows the status of 
the specific content: 

Icon Function 

 

This content is not installed yet. 

 

This content can be updated. 

No icon This content is installed and up-to-date. 

• Type: The type of content. 

• Installed: The column indicates whether the content was installed. It also displays the amount 
of storage space the installed content currently uses, and an icon that shows where the content 
is installed: 

Icon Function 

 

This content is installed in the internal memory of your Becker Traffic Assist (Flash). 

 

This content is installed on the memory card. 
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• Available: This column displays the amount of storage space needed to install this content 
element, and an icon that shows the location of the available content: 

Icon Function 

 

This content can be downloaded from the Internet. When you initiate Perform Operations, 
the Content Manager downloads it from the product site, and installs it on your Becker 
Traffic Assist. (This service may not be available on all devices.) 

 

This content is already downloaded to your PC. The Content Manager can install it on 
your Becker Traffic Assist without an active Internet connection. 

 

This content is available on DVD. The Content Manager can install it on your Becker 
Traffic Assist without an active Internet connection. 

1.3.6 Contents list filters (available in Advanced mode only) 
There are three filters to narrow the Contents list: Status, Type and Location. 

• Status: Filters contents based on their status:  

• All: Displays all contents. 

• Installed: Displays only contents installed on the device. 

• Not installed: Displays only available contents that are not installed on the device. 

• Updatable: Displays contents for which a newer version is available than the one 
installed. 

• Updatable or not installed: Displays all contents that are updatable or not installed. 

• Up-to-date: Displays all installed and up-to-date contents. 

• Type: Filters contents based on their type. 

• Location: Filters contents based on their storage location. 

 

NOTE: Not installed content items only appear in the list when Location is set to All. 



 

12   

2 Managing contents 

2.1 Installing all new contents 
To upload all available new contents to the device, do the following: 

1. Click Install all.  (the button remains inactive if there is no content to upload) 

2. Click Yes to confirm the operations summary. 

3. Click OK when the process is finished. 

2.2 Updating all contents 
To upload all available content updates to the device, do the following: 

1. Click Update all.  (the button remains inactive if there is no content to upload) 

2. Click Yes to confirm the operations summary. 

3. Click OK when the process is finished. 
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3 Fine-tuning contents in Advanced 
mode 

3.1 Installing contents 

NOTE: Only non-installed contents can be installed. They have an icon next to their name 
in the Contents list. 

To upload the selected contents to the device, do the following: 

1. Select the content items from the Contents list. There are several ways to do this: 

• Click on a content item in the Contents list. To select multiple items, use either the Shift 

or the Ctrl key. Click Install in the Content menu or click  in the toolbar. 

• Drag-and-drop the content items to the Operations window. 

• Double-click a content item. 

• Right-click on a content item and select Install. 

2. Execute the actions by clicking Perform operations in the Operation menu or by clicking 

 in the toolbar. 

3. Click Yes to confirm the operations summary. 

4. Click OK when the process is finished. 

3.2 Updating contents 

 
NOTE: Only non-up-to-date contents can be updated. Non-up-to-date contents have an 
icon next to their name in the Contents list. 

To update the selected contents, perform the following steps: 

1. Select the content items from the Contents list. There are several ways to do this: 

• Click on a content item in the Contents list. To select multiple items, use either the Shift 

or the Ctrl key. Click Update in the Content menu or click  in the toolbar. 

• Drag-and-drop the content items to the Operations window. 

• Double-click a content item. 

• Right-click on a content item and select Update. 

2. Execute the actions by clicking Perform operations in the Operation menu or by clicking 

 in the toolbar. 

3. Click Yes to confirm the operations summary. 
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4. Click OK when the process is finished. 

3.3 Removing contents 

 

NOTE: Only installed contents can be removed. 

To remove selected content elements, do the following: 

1. Click on a content item in the Contents list. To select multiple items, use either the Shift or the 
Ctrl key. 

2. Click Remove in the Content menu, click  in the toolbar, or right-click on the selected 
contents and click Remove. 

3. Execute the actions by clicking Perform operations in the Operation menu or by clicking 

 in the toolbar. 

4. Click Yes to confirm the operations summary. 

5. Click OK when the process is finished. 

 

TIP: You can perform different content operations (installing, updating, removing) at the same 
time. Just group them in the Operations window together, and click on Perform operations in 

the Operation menu, or click  in the toolbar. 



 
 

  15

4 Tools and Options 

The tools and options in the Content Manager can be accessed in the Tools menu. 

4.1 Backups 
You can make a duplicate copy of the device contents and store it on your PC. Backups are useful to 
have as a safety precaution in case you unintentionally delete content from your device. You always 
have licence to the content that you purchased with your device and you can use the Content 
Manager to re-download this at any time. Backups can come in handy to save time with downloads or 
if your PC is not connected to the Internet. 

4.1.1 Creating backups 
To backup your data, do the following: 

1. Select Backup from the Tools menu to open the Manage backups window. 

2. Click on Backup in the Manage backups window, then select Backup. 

3. Use the radio buttons to select the data to save: 

• full backup 

• backup user data only 

4. The default backup folder is displayed. To define a different one, click I want to define a folder 
manually, and then enter the path of the desired location, or click Browse and select the 
folder. 

5. Click OK to start the backup process. 

6. Click OK when the process is finished. 

4.1.2 Restoring backups 
To restore backed up data to the device, do the following: 

1. Select Backup from the Tools menu to open the Manage backups window. 

2. Select a previously saved backup from the list. 

3. Click Restore. 

4. Click Yes to start restoring your data. 

5. Click OK when the process is finished. 

 

NOTE: The time needed for backup or restore can vary considerably depending on the size of 
the files you selected to backup or to restore. 
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4.1.3 Removing backups 
To remove backed up data, do the following: 

1. Select Backup from the Tools menu to open the Manage backups window. 

2. Select a previously saved backup from the list. 

3. Click Remove. 

4. Click Yes to delete the backup. 

4.2 Licences 
You can list and manage the access licences in your Becker Traffic Assist. 

When your Becker Traffic Assist is connected to the Content Manager, the licences found on the 
device are automatically saved in the device profile. In this way the Content Manager can recover 
damaged or lost licences automatically. 

In the Tools menu click Licences to see the list of licence files installed on your device. Different 
content elements may have separate licence files associated with them. A content is only visible in 
the navigation software if the appropriate licence is active. 

To change the status of the installed licences, highlight one of the list items, and then click Activate 
for an inactive licence, or Deactivate for an active one. 

 

NOTE: If you deactivate some of your licences, a part of the content installed on your Becker 
Traffic Assist becomes invisible. To be able to use them again, you need to return here and 
activate the necessary licence or licences. 

4.3 Content DVDs 
The Content Manager can read and catalogue the content of DVDs that are bought for or enclosed 
with the product. In this way you can install or reinstall content items on your device without an 
Internet connection. 

When this function is started the first time, the list is empty. If you have a content DVD in your PC, 
click Add, and the Content Manager checks the content of the DVD and puts the name of the disc on 
the list. 

If you no longer need one of the listed DVDs, highlight it, and click Remove. The DVD is deleted from 
the list, and the catalogue of its content is cleared from the Content Manager. 

4.4 Device profiles 
Existing device profiles can be edited and removed in the Device profiles menu. The current device 
profile is displayed in bold. 

 

NOTE: New device profiles can only be created when you start the Content Manager with a 
new device connected. 

4.4.1 Removing device profiles 
To remove a device profile that is no longer needed, do the following: 

1. Select Device profiles from the Tools menu. 

2. Click on the device profile you want to remove. 

3. Click Remove. 
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4. Click Yes to proceed with deleting the selected device profile. 
 

 

NOTE: The currently used profile cannot be deleted. 

 

 WARNING: When removing a device profile, all backups and licences saved with the profile 
will be deleted from the PC. 

4.4.2 Editing device profiles 
To edit a device profile, do the following: 

1. Select Device profiles from the Tools menu. 

2. Click on the device profile you want to edit. 

3. Click Edit. 

4. Modify the profile parameters: 

• To change the name of the profile, enter the desired profile name. 

• To change the type of the device, select the appropriate device type from the list of available 
device types. 

5. Click OK to confirm the changes. 

4.5 Preferences 
Settings can be configured in the Preferences menu. Settings are displayed on the following tabs: 

• General 

• Visualisation 

• Connection 

4.5.1 General 
The General preferences window has the following sections: 

• Language: The language of the Content Manager can be changed by selecting a language 
from the drop-down menu. 

• Mouse wheel speed: The mouse wheel speed in the Contents list can be changed by 
moving the slider to the desired position. 

• Cache: When a content item is installed on the device from the Internet, the content item is 
also saved automatically on the computer in a cache. If a content item is stored in the cache, 
later it can be installed again on the device without an Internet connection. The overall size of 
all content items stored in your computer is displayed. The cache can be emptied by clicking 
Clear. 

• Backup: You can suppress or re-activate the warning message at each startup that is 
displayed if you have not created a backup of the content of your navigation system. 

 WARNING: By clearing the cache, all saved contents are deleted from the PC. If you need to 
install them again later, you need to download them using the Internet connection of the PC. 
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4.5.2 Visualisation 
You can customise the look of the Contents list. 

4.5.2.1 Customising table fonts 
To change table fonts, do the following: 

1. Enable custom fonts by selecting Enable customised fonts in tables. 

2. Click Font. 

3. Select the desired font and click OK. 

4.5.2.2 Customising table colours 
You can define custom foreground and background colours for the different content types. 
Foreground colour is the colour of the text, while background colour is the colour of the cell. By 
choosing custom table colours, content types are easier to distinguish. 

To change table colours, do the following: 

1. Enable customised table colours by selecting Enable customised colours in tables. 

2. Click on the button next to a content type in the foreground or the background column. 

3. Select the desired colour. 

4. (optional) Repeat the above steps to change more colours. 

5. Click OK to finish the process. 

4.5.3 Connection 
Settings in the Connection preferences window determine how the Content Manager is connected 
to the Internet: 

• Direct connection to the Internet: The PC has a direct Internet connection. The Content 
Manager can use this channel to access the remote database of existing updates. 

• Manual proxy configuration: If your PC is connected to the Internet via a proxy server, you 
need to enter the proxy parameters in order to gain access to the Internet. If you are not 
experienced in configuring proxy connections, ask for the help of your network administrator. 

 

NOTE: The changes take effect only after clicking OK. 
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5 Troubleshooting 

In case of erroneous or suspicious behaviour of the Content Manager, check the log file for details. 

On Windows Vista computers the log file can be found at the following location: 

C:\Users\<user name>\AppData\Roaming\mybecker.com\Content Manager\Log\cm.log 

On Windows XP computers the log file can be found at the following location: 

C:\Documents and Settings\<user name>\Application Data\mybecker.com\Content 
Manager\Log\cm.log 
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6 Uninstalling the Content Manager 

To uninstall the Content Manager, do the following: 

1. Exit the Content Manager if it is running. 

2. Click Start > All Programs. 

3. Open Becker. 

4. Select Uninstall Content Manager. 

5. Click Next to start the uninstall process. 

6. The location of the Content Manager is shown. Click Next to continue 

7. A checkbox appears with the text 'I want to delete all profiles and backups'. It is 
recommended to leave it unchecked if you continue using your Becker Traffic Assist. This way 
your backups and profiles will be accessible later if you install the Content Manager again. 

8. Click Uninstall. To see the details during the process, click Show Details. 

9. Click Finish to exit when the process is complete. 


